Error SharePoint – “Search application ‘{0}’ is not ready”

En este Post quiero compartir con ustedes la solución al problema que se presenta en SharePoint:

“Search application ‘{0}’ is not ready”

Tengo un servidor MOSS funcionado correctamente (Hasta el día que llegaron los errores), cierto día me prepare para generar un respaldo de los sitios completos con la herramienta que trae la Administración Central, y me encontre ante la sorpresa de que no se podían realizar, marcaba un error que indicaba que no se había asignado un Indizador al servidor, despues de revisar los servicios compartidos, revisar que el servicio de búsqueda estuviera habilitado, usuarios contraseñas, etc, etc, tal parece que el error habia desaparecido (porque sucedio, la verdad no lo se). 

Pero despues de esto me encontre con que ahora aparecia un error mas, pero ahora decía “Search application ‘{0}’ is not Ready”, me puse a revisar los logs del servidor en el visor de sucesos y veia que cada minuto salia el siguiente error,

El método Execute de la definición de trabajo Microsoft.Office.Server.Search.Administration.IndexingScheduleJobDefinition (ID 5a247eed-8640-48a2-973a-6f7ccd36b97f) lanzó una excepción. A continuación se incluye más información.

Search application ‘{0}’ is not ready.

For more information, see Help and Support Center at

 

Sin  saber aún como solucionar el problema y menos que fue lo que lo ocasionó empece a buscar alguna solución, pero sin mucha suerte en encontrarla, por mera intuición mas o menos pensando que pudiera ser empece a intentar hacer un respaldo parte por parte, es decir primero la administración central, despues sitios, etc etc y me di cuenta que eso si funcionaba, motivo por el cuál despues de intentar hacer del servicio compartido llegue a la conlusion que ahí estaba el problema, Servicio Compartido, despues de mucho buscar la solución encontre este foro donde una persona tenia el mismo problema.

Despues de leer una infinidad de comentarios, lo que hice para solucionar el problema fue crear un nuevo servicio compartido, despues le asigne las demas aplicaciones y posteriormente lo puse como predeterminado, inicie la importación de perfiles, y posteriormente las audiencias, claro primero lo hice en un sitio de pruebas por si acaso algo pasara, posteriormente elimine el Primer Servicio Compartido y finalmente el error se soluciono.

Se ha almacenado correctamente la instantánea del Registro de la configuración de la aplicación en la base de datos.

Contexto: aplicación ‘SharedServices2′

 

 

 

About these ads

No comments yet

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

%d personas les gusta esto: